We have a fair amount of code which manually builds strings like `D123` like this:
$object_name = "D".$revision->getID();
It would be nice to centralize this into the objets, so we just call:
$revision->getObjectName();
However, "object name" is pretty much the vaguest possible name for this. I've primarily avoided building this because `getObjectName()` is such an ambiguous, garbage method name.
It would be nice to come up with some better name to identify the `D123`, `T123`, `rX` sort of strings we use as local/human object identifiers.