Page MenuHomePhabricator

"Send an email when projects include X" Herald rule ignores the "Ignore subscriber changes" email notification preference
Closed, InvalidPublic

Description

On https://secure.phabricator.com/settings/panel/emailpreferences/ I set months ago

Maniphest Tasks: | ⚪ Ignore | A task's subscribers change.

Still I receive email notifications about "[Changed Subscribers]" (no other actions involved or listed in the notification email). Latest example is https://secure.phabricator.com/T4171#140456
Note that I am a "watcher" of the "Wikimedia" project which is associated to https://secure.phabricator.com/T4171

I consider this unexpected behavior.

I have checked that I have only one email address configured and it is for my account @aklapper hence no other potential second account involved here.

Event Timeline

aklapper created this task.Oct 15 2015, 1:10 PM
aklapper updated the task description. (Show Details)
aklapper added a project: Notifications.
aklapper added a subscriber: aklapper.

aklapper (Andre Klapper)

  • Mail Tags: This mail has tags which control which users receive it, and this recipient has not elected to receive mail with any of the tags on this message (Settings > Email Preferences).
  • Forced by Herald: This recipient was added by a "Send me an Email" rule in Herald, which overrides some delivery settings.

You should be able to find this message in /mail/ to get this information and some additional details.

Basically, "Send me an Email" as a Herald action is very strong and overrides almost all other settings. This allows you to receive notifications about events which you'd normally want to ignore but which are particularly important.

See also this in the transcript:

If you have the rule add you as a subscriber instead, delivery won't be forced.

There's no way to "send me an email as a low-priority action" right now.

aklapper closed this task as Invalid.Oct 15 2015, 1:59 PM
aklapper claimed this task.

Herald! Thank you Evan.
Yes I had forgotten about that. (Wondering how I could have found out though.)
I've disabled the personal rule.
I'm closing this task as invalid and will adjust the task summary to describe what was the PEBKAC here.

aklapper renamed this task from Receiving Subscriber change email notifications for watched projects though set "Ignore" in email preferences to "Send an email when projects include X" Herald rule ignores the "Ignore subscriber changes" email notification preference.Oct 15 2015, 2:01 PM

This is definitely something which can be improved -- the transcript has been updated recently and is fairly clear ("Forced Mail", "...ignoring notification preferences..."). The /mail/ UI is fairly clear too, but hard to find right now. Other UIs and interactions haven't been updated as recently and aren't as clear.

I expect to improve /mail/ and make it easier to find in connection with T5791, T9161, etc., but this is just a huge ball of highly-connected tasks that will take time to work through. It may eventually make sense to rename or split this action apart ("Force an email to...", "Send an email to...") but I want to see if we can make things clearer in other ways first.

But this is working as intended at the actual delivery level, just not nearly as clear as it should be at the UI level right now.