Page MenuHomePhabricator

Allow my own "planned changes" to be cancelled
Closed, ResolvedPublic

Description

Use case: I plan changes on my own (already accepted) diff to handle some edge case, and, after some investigation, decide that it's not necessary. Right now my options are:

  1. Post a dummy diff update to go back from "changes planned" to "accepted"
  2. Request review again, and then actually get someone to re-accept it

Neither of those seem ideal.

Event Timeline

staticshock raised the priority of this task from to Needs Triage.
staticshock updated the task description. (Show Details)
staticshock added a project: Differential.
staticshock added a subscriber: staticshock.
chad added a subscriber: chad.Mar 20 2015, 3:33 PM

Is Abandon Revision not working?

Abandon doesn't seem right, because it implies that the changeset is being abandoned. I just want to abandon the changes I was planning, and land it as-is.

I can't reproduce this, the revision immediately goes back into "Accepted" for me:

Do you have differential.sticky-accept turned off?

chad added a comment.Mar 20 2015, 3:52 PM

Ah, sorry I mis-read the question.

Ah, requesting review auto-accepts in this situation? I didn't realize that, thanks.

Yeah, unless differential.sticky-accept is off (which is intentional).

epriestley closed this task as Resolved.Mar 20 2015, 3:59 PM
epriestley claimed this task.

Presuming resolved, yell if not.