Page MenuHomePhabricator

https://secure.phabricator.com/maniphest/ times out when not logged in
Closed, ResolvedPublic

Description

https://secure.phabricator.com/maniphest/ times out when not logged in.

>>> UNRECOVERABLE FATAL ERROR <<<

Maximum execution time of 30 seconds exceeded

/core/lib/libphutil/src/parser/PhutilTypeSpec.php:1909


┻━┻ ︵ ¯\_(ツ)_/¯ ︵ ┻━┻
>>> UNRECOVERABLE FATAL ERROR <<<

Maximum execution time of 30 seconds exceeded

/core/lib/phabricator/src/infrastructure/storage/lisk/LiskDAO.php:944


┻━┻ ︵ ¯\_(ツ)_/¯ ︵ ┻━┻

Event Timeline

elesh created this task.Mar 13 2015, 3:54 AM
elesh raised the priority of this task from to Needs Triage.
elesh updated the task description. (Show Details)
elesh added a subscriber: elesh.
qgil added a subscriber: qgil.Mar 13 2015, 8:40 AM

I can reproduce this.

For what is worth, https://phabricator.wikimedia.org/maniphest/ does work for anonymous users.

epriestley triaged this task as High priority.
epriestley closed this task as Resolved.Mar 14 2015, 8:46 PM

This was caused by a miscast of a floating point value to an integer, which could incorrectly truncate it and leave us trying to load the same page over and over again in a loop. It required a particular combination of subpriority value, paging boundaries, and task visibility; we happened to have all three. rP106ca70a should resolve it.