Page MenuHomePhabricator

Remarkup object linking for Legalpad for signee status
Closed, DuplicatePublic

Description

Certainly not life or death stuff but this would be super handy I'm finding as we begin to use legalpad more seriously :)

Something that would make the experience more integrated:

  • If I could show the status of a signee like {L1, user=chasemp} where it expands to the name of the document and shows the use like. "Important Document - Chasemp" and it would be crossed out if that user has signed.

Right now to link to the state of a signee it is a saved search and cntrl+f, which is ok, but for building check lists for user verification it would be awesome if the above was possible.

Related Objects

Event Timeline

chasemp raised the priority of this task from to Needs Triage.
chasemp updated the task description. (Show Details)
chasemp added a project: Restricted Project.
chasemp added a subscriber: chasemp.
chasemp renamed this task from Remarkup object linking for Legalpad to Remarkup object linking for Legalpad for signee status.Jan 9 2015, 3:19 PM
chasemp updated the task description. (Show Details)
epriestley added a subscriber: epriestley.

You should be able to override renderObjectEmbed() in LegalpadDocumentRemarkupRule and have it look for a user in $options, then use PhabricatorPeopleQuery and LegalpadDocumentSignatureQuery to check if the user has signed the document.

Maybe render the tag with a red dot if they haven't and a green dot if they have, so it's not ambiguous with archived/active objects.

(Ideally, we would batch these queries, but I think it's OK to implement them as single queries for now, since this workflow/feature is specialized.)

Adding the username to the rendered output would be nice too.

Finally, document the option in the Remarkup reference.

epriestley triaged this task as Wishlist priority.Jan 9 2015, 3:22 PM
epriestley added a project: Remarkup.
qgil added a subscriber: qgil.Jan 9 2015, 3:53 PM

I guess it's true that only people now who can edit a doc can see others signee status, and this leaks that info. Wanted to make note in case that's important :) I can't think of why a whether a document is signed would be private, but probably if this task is desirable it should follow the same policy logic as other mentions.

Ok just my possibly relevant thought! thanks

This wouldn't leak the info (if you were not allowed to know about the signature status, the document would appear un-signed), but it might cause some confusion. Maybe using "red" for not signed, "green" for signed, and grey for "you aren't allowed to know" would resolve that.

After some discussion, this feels like it got more complicated and is largely inferior to "Signature Requests", a planned feature in T5505. I'm just going to merge this into that task.

epriestley closed this task as a duplicate of T5505: Plan Legalpad v2.Jan 12 2015, 10:39 PM