Page MenuHomePhabricator

Make subcription on comment optional
Closed, DuplicatePublic

Description

Our problem is that we get to many E-Mails from Phabricator.
The reason for that is that you get subscribed to a task if you write something in it(picture below) by default.

It is common that we need just one piece of information from someone in a big task.
E.g.: boss needs to give his "OK/Go" in a software or hardware project.
After his answer the person is not interested in the task anymore but now gets all E-Mail, notifications and discussions from this task.

We think it would be the best solution if subscription would be optional.

Event Timeline

niv created this task.Mar 29 2017, 12:13 PM
chad closed this task as Invalid.Mar 29 2017, 1:54 PM
chad added a subscriber: chad.Mar 29 2017, 2:27 PM

I'm not interested in pursuing this, mostly it does not solve the core problem of "too may emails". (see Describing Root Problems) If the problem really is "my boss doesn't want to unsubscribe after a comment", then the problem is too narrow for us to have an upstream solution to. Making it an option is very disruptive to everyone else.

Other administrators can assist you in finding and configuring Phabricator in the "too many emails" scenario, we even have command-line tools to tell you who really is getting too much mail, and who is just complaining. Also see T8227 for our stance on adding options to Phabricator in general.

I merged this into T5791 which is the closest equivalent of adding more options to have Phabricator not send email in highly specific cases.