libphutil made call to undefined function id(), fataling on Windows
Closed, ResolvedPublic

Description

Version information:

phabricator 111c63955155046bbd57c3836c78d460ebe13dfb (Sat, Nov 5)
arcanist e17fe43ca3fe6dc6dd0b5ce056f56310ea1d3d51 (Fri, Oct 21)
phutil 40e473e057885dab5de4fb42901f7fff2d340a6a (Sat, Nov 5)

When executing arc diff command this happens (also checked with libphutil/scripts/utils/utf8.php):

PHP Fatal error:  Call to undefined function id() in <dir>\libphutil\src\moduleutils\PhutilBootloader.php on line 93

Thanks.

Regards,
Juan

cxzzero created this task.Nov 9 2016, 12:40 PM
chad added a subscriber: chad.Nov 9 2016, 3:28 PM

This report doesn't look to include reproduction information.

For me seems to be quite good the information provided, but I try to explain myself with more details:

  • Firstly, I have updated phabricator, arcanist and arcanist to latest versions (detailed above)
  • Then, I try to make a revision while executing command arc diff
  • Error is displayed

PHP Fatal error: Call to undefined function id() in <dir>\libphutil\src\moduleutils\PhutilBootloader.php on line 93

Thanks in advance

chad added a comment.Nov 9 2016, 4:16 PM

We need to know how to reproduce bugs in order to fix them. Please take the time to give us all information needed about your environment so we can reproduce the bug. Id() missing means something is dramatically wrong with your installation, as no part of Phabricator is expected to run without access to libphutil and its functions.

The current steps are incomplete for us to reproduce the bug.

Thanks chad. I will check if there is a problem with the installation and let you know.

Definitely there was a problem with the installation, for some reason the files got corrupted and downloading a fresh installation solved the problem.

Thanks,
Juan

chad closed this task as Resolved.Nov 9 2016, 6:06 PM
chad claimed this task.

whew! good to hear.