Page MenuHomePhabricator

Use fixed-width (monospaced) font for (re)markup textareas
Closed, InvalidPublic

Description

I started writing reply to T5395 but decided to open a new ticket as I think this deserves more attention.

Is there any global configuration setting to set monospaced font for all users by default? It looks that is removed because of T7764 and now, all I could find is that every user needs to change it for itself? Before that, @jpoehls could set default font for everyone.

Current default setting makes no sense to me and I am trying to understand why would someone want it non-monospaced.
For example, Stackoverflow editor has monospaced font by default (using markdown), Wikipedia also (using wiki markup) , Pastebin, WordPress, etc...

Remarkup textareas should use monospaced font in more accessible way, primarily because of aligning text (eg. when using tables). My remarkup documents look like a mess (by default).

The rule of thumb here should be simple

  • if content of textarea is some sort of markup and you can't change font (not formatted), textarea should be monospaced
  • if content of textarea is WYSIWYG (formatted) then it can be whatever user chooses

WordPress editor has a really good solution for this. There are two tabs (buttons) above textarea

  • Visual (formatted)
  • Text (HTML markup, monospaced)

As an extra, it remembers user choice for the next time when editor opens so you don't need to set it every time.

Event Timeline

bbrdaric created this task.Feb 9 2016, 1:56 PM
chad added a comment.Feb 9 2016, 2:49 PM

I'm going to merge this over this since it's not a bug report nor a valid feature request (since a per user option already exists).

chad closed this task as Invalid.Feb 9 2016, 2:50 PM
chad claimed this task.
chad added a comment.EditedFeb 9 2016, 3:11 PM

In general this falls under "feedback" or "design feedback" (see T10208). We don't have any decent mechanic for taking and holding these opinions in Phabricator. For "design feedback" we currently limit it to what is on the current Roadmap. This helps our small team (2 people) remain focused on building and thinking about the current product.

My main concern overall is we're not apt to make large disruptive changes to how everyone works without there being significant upside. Right now the < 1% of users who prefer the fixed width for typing already have a setting to make it default. This feels like the right approach, since you can't assume everyone using Phabricator is an engineer (in fact, most likely are not). I don't see any gains by making it the default for everyone, since it would be hugely disruptive and I imagine we'd get fairly vitriol feedback accordingly.